Instalar Subclipse en Eclipse

Tamaño de letra:

La última versión de Subclipse. EasyEclipse.

En el arterior artículo ya comenzamos los preparativos. Se decidió instalar Subclipse para integrar el control de versiones SVN con el entorno de desarrollo, además de crear nuestra copia de trabajo que definimos tras la instalación de Eclipse+XAMPP y nuestro repositorio local creado en un directorio en C:/ (exactamente en: C:/REPOSITORIO).

Si no quieres instalar Subclipse puedes descargar EasyEclipse que viene con los complementos más utilizados. Su web: www.easyeclipse.org. Yo voy, como ya he hecho anteriormente con otros complementos, a instalarlo desde cero y mostrarlo a aquellos usuarios que quieren tener las últimas versiones actualizadas o que quieren hacerlo a mano.

Para su instalación, en Eclipse, vamos al menú Help ?Install New Software (Ayuda ?Instalar nuevo software). Ahí se solicitará una URL desde donde se descargará el plugin. No voy a poner una cualquiera o la URL que me valga a mí, porque dentro de un tiempo estará obsoleta, así que voy a instalar una que sea compatible con mi/tu sistema de control de versiones y con mi/tu instalación de Eclipse:

Versión adecuada de Subclipse

Voy a la web oficial de Subclipse, observo un menú en el que hago clic que pone "Download and Install". En el apartado "Current Release" vienen escritas las necesidades de instalación.

En mi caso tengo instalado lo siguiente:

  • Eclipse versión 3.7.0
  • Subversión 1.7.0 (Esto lo puedes ver en el menú de TortoiseSVN, pulsando con el botón derecho en cualquier carpeta TortoiseSVN?Acerca de).

Esto significa, viendo la web de Subclipse, que la versión que necesito de Subclipse es la 1.8.x. Observo, por lo tanto que el enlace para la actualización de Subeclipse es este: Links for 1.8.x Release ?http://subclipse.tigris.org/update_1.8.x

Esa URL es la que pongo en la ventana de Eclipse anterior (Help ?Install New Software), en el cuadro de texto "Work with" y pulso Enter.

En unos segundos deberá aparecer un listado con los componentes a instalar:

Instalar Subclipse

Puedes desplegar "Subclipse" y "SVNKit" y seleccionar lo que te interesa instalar. Para no tener problemas, selecciona todo, ya que si te falta algún componente es posible que después te lance algún error. Yo instalo todo excepto los que llevan la etiqueta de no requeridos (no required), los selecciono y pulso Next (siguiente) y continúo con el asistente de instalación. Nueva ventana: "Installing Software" ? tras la instalación solicita reiniciar Eclipse. Reinicio ahora (Restar now).

Lo siguiente que veremos será cómo añadir al repositorio el proyecto creado.

Última actualización: Viernes, 07 Diciembre 2012
Escribir un comentario
Antes de publicar un comentario, usted debe aceptar nuestras condiciones de uso: Condiciones de uso. Debido al spam, todos los comentarios serán moderados. Normalmente se responde en unos minutos, refresca los comentarios para comprobarlo.



 
Visitas: 8524284